Viewing Probe Test Results

yesterday I ran the following measurement:

When I look at the Latest Results all I get is an overall text report showing RTT (presumably this is Avg over the 16 pings I set) and 0% Packet Loss:

Probe ASN (IPv4) ASN (IPv6) Time (UTC) RTT Packet Loss
60998 702 2023-02-09 14:10 80.612 0.0%

But if I run the same ping test from Global Traceroute I get a nicer verbose output:

PING ( 56 data bytes
Response from icmp_seq=0 ttl=233 time=81.928062 ms
Response from icmp_seq=1 ttl=233 time=81.817491 ms
Response from icmp_seq=2 ttl=233 time=81.593709 ms
Response from icmp_seq=3 ttl=233 time=81.60163 ms
Response from icmp_seq=4 ttl=233 time=81.590189 ms
Response from icmp_seq=5 ttl=233 time=81.570347 ms
Response from icmp_seq=6 ttl=233 time=81.456015 ms
Response from icmp_seq=7 ttl=233 time=81.544104 ms
Response from icmp_seq=8 ttl=233 time=81.676437 ms
Response from icmp_seq=9 ttl=233 time=81.769646 ms

— ping statistics —
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max = 81.456015/81.928062/81.654763 ms

Source address is


I cant see any obvious option to change the reporting output - even under advanced options when setting up the measurement. Am I missing something obvious or is this just the way it is?

Ironically sending the same 10 pings from the same probe Global Traceroute took less than 1m30s and after 6 mins I am still waiting for RIPE to complete (status = ongoing and I tried refreshing page in case it was stuck).

You are showing the web UI of Atlas vs. terminal(ish?) output of another tool. This is what you get if you use the RIPE Atlas CLI:

$ time ripe-atlas measure ping --target --probes 5

Looking good! Measurement 49878155 was created and details about it can be found here:

Connecting to stream...

PING (resolved on server)
48 bytes from via probe #1004871 ( ttl=117 times=7.664 ms, 7.444 ms, 7.396 ms
48 bytes from via probe #1003111 ( ttl=113 times=18.174 ms, 16.247 ms, 18.003 ms
48 bytes from via probe #1004099 ( ttl=58 times=75.476 ms, 86.843 ms, 79.331 ms
48 bytes from via probe #1002766 ( ttl=117 times=22.821 ms, 23.028 ms, 21.333 ms
48 bytes from via probe #53026 ( ttl=60 times=18.82 ms, 17.421 ms, 18.292 ms

--- ping statistics ---
15 packets transmitted, 15 received, 0.0% loss
rtt min/med/avg/max = 7.396/18.292/29.220/86.843 ms

Disconnected from stream

real	0m9.801s
user	0m0.183s
sys	0m0.046s

Note: it took 10 seconds in total. Of course if there’s one result that keeps on not coming… then one will wait longer.

The one-off measurements are officially closed after 10 or 15 minutes - because by that time the results either came in or they never will :slight_smile:

1 Like

Thanks. I am pretty new to this. The output I provided was from the Global Traceroute Webtool (pretty handy for basic single probe ping / trace / dns tests as requires no credit and easier to find specific probes imho):

Is there any easy way to access Atlas CLI for a HW probe or is this the only way:

If the latter seems a little strange that a free 3rd party tool offers CLI style output when Atlas itself doesnt as standard.

Welcome! :slight_smile:

The RIPE Atlas CLI (aka Magellan) is a tool that is maintained by the Atlas team itself. There are some other similar tools. RIPE Atlas internally uses JSON results; this tool is one that makes them simple to read. The web UI also does its best to render the results in a browser-friendly way.

I guess it would be possible to add a page/tab in the UI for measurement results to “show the results like you would in a terminal”. Is that what you’re looking for?

1 Like

Thanks & yes that sounds great. Coming from a Networking environment where pretty much everything is CLI based I find it much easier to see results as they happen and get the results in real time rather than wait 10mins to confirm a result (especially when doing live testing for an ongoing fault).